heymow.com - Lawn Mower Racing Forum
October 25, 2014, 03:37:31 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
Want to Join our site? CLICK HERE
 
   Home   Help Search Calendar Staff List Links Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: 15.5hp Briggs single ohv  (Read 579 times)
0 Members and 1 Guest are viewing this topic.
Hrupka Farms
Newbie
*

Karma: 0
Offline Offline

Gender: Male
Posts: 15



View Profile
« on: February 15, 2014, 12:57:21 PM »

I have a 15.5hp Briggs single ohv. It's set up for gp. When I try to throttle it nothing happens it just stays at idle. The thing has me puzzled. Any information would be helpful confused
Logged

Matt H
A/P #0.07 Toro 920 - Known as "Just Under"
F/X #0.07 ??????? - Known as "Almost There"
Jim Knutson
Mow-Forum Junkie
***

Karma: 10
Offline Offline

Gender: Male
Posts: 1305


i didnt break it......i modified it!


View Profile
« Reply #1 on: February 16, 2014, 08:43:19 AM »

is the throttle cable hooked to the carb?
Logged

Jim Knutson
2009 o.l.m.r.a. mod-x points champion
2010 o.l.m.r.a. mod-x points champion
2011 northwest regional champion pro-x
2012 MHLMR FX champion
mount hood lawnmower racing
PACE MOWERSPORTS
willenglish
Turf Warrior
**

Karma: 2
Offline Offline

Gender: Male
Posts: 196


View Profile
« Reply #2 on: February 16, 2014, 09:25:48 AM »

Check for a broken throttle shaft...
Logged

William L. English, jr.
heymow.com - Lawn Mower Racing Forum
« Reply #2 on: February 16, 2014, 09:25:48 AM »

 Logged
Hrupka Farms
Newbie
*

Karma: 0
Offline Offline

Gender: Male
Posts: 15



View Profile
« Reply #3 on: February 16, 2014, 10:21:37 AM »

the throttle cable is hooked up to tye governer plate but when i push the governer arm it throttles up it just has me puzzled
Logged

Matt H
A/P #0.07 Toro 920 - Known as "Just Under"
F/X #0.07 ??????? - Known as "Almost There"
crazycraftsman
Turf Warrior
**

Karma: 1
Offline Offline

Gender: Male
Posts: 636


Nothing like fresh cut grass!!


View Profile WWW
« Reply #4 on: February 16, 2014, 10:48:52 AM »

Take the air filter off and watch the throttle butterfly to seeif it's moving inside carb. Try diss connecting linkage and turnig throttle butterfly by hand when running.
Logged

owen
Lawnmower Racing in B.C   Canada
www.lawnmowerracingfv@blogspot.com
nip 19
Turf Warrior
**

Karma: 0
Offline Offline

Gender: Male
Posts: 181


if its fast count me in


View Profile
« Reply #5 on: February 16, 2014, 11:55:07 AM »

  Do you have a return spring ? Maybe it's overriding your governor spring
Logged

2011 GLMRA FX champion
2011 SRUSAAO FX champion.   Kevin
Hrupka Farms
Newbie
*

Karma: 0
Offline Offline

Gender: Male
Posts: 15



View Profile
« Reply #6 on: February 16, 2014, 07:28:25 PM »

the throttle buterfly does move and accelerates when i twist it
i do have a return spring but it is hooked up to the throttle cable so it shouldnt interfere with the governer
im thinking that it could be the spring that connects the governer arm to the governer plate might be weak but im not sure
Logged

Matt H
A/P #0.07 Toro 920 - Known as "Just Under"
F/X #0.07 ??????? - Known as "Almost There"
crazycraftsman
Turf Warrior
**

Karma: 1
Offline Offline

Gender: Male
Posts: 636


Nothing like fresh cut grass!!


View Profile WWW
« Reply #7 on: February 16, 2014, 08:39:10 PM »

Got a picture of your linkage setup?
Logged

owen
Lawnmower Racing in B.C   Canada
www.lawnmowerracingfv@blogspot.com
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!


Google visited last this page October 23, 2014, 06:07:07 AM